华为路由器的配置 – 我的笔记本

静态路由配置

路由器中包含静态路由表和动态路由表。静态路由表是管理员手动配置的,而动态路由表是路由器通过协议自动学习到的。
举例:如下图所示,有A、B、C三个路由器,相关配置已在图上标示。现在需要在A上进行配置,打通去往192.168.3.0/24192.168.5.0/24的网段路由,同时去往其他任一网段的路由从192.168.6.2这个接口转发出去。
file

  1. 在路由器A上配置去往192.168.3.0/24和192.168.5.0/24网段的路由
    <HUAWEI>system-view
    [HUAWEI]sysname RA
    [RA]interface gigabitethernet 0/0/1
    [RA-Gigabitethernet0/0/1]ip address 192.168.1.1 255.255.255.0 // 配置接口的IP地址
    [RA]ip route-static 192.168.3.0 255.255.255.0 192.168.4.2 // 配置去往192.168.3.0网段的静态路由,去往该网段的数据包交给下一跳,地址为192.168.4.2
    [RA]ip route-static 192.168.5.0 255.255.255.0 192.168.4.2 // 配置去往192.168.5.0网段的静态路由,去往该网段的数据包交给下一跳,地址为192.168.4.2
  2. 在路由器A上配置去往其他任何一个网段的路由(默认路由)
    [RA]ip route-static 0.0.0.0 0.0.0.0 192.168.6.2 // 配置去往其他任一网段的默认路由,数据包交给下一跳,地址是192.168.6.2

动态路由配置

动态路由的配置有三种协议:距离矢量路由协议、链路状态路由协议和平衡混合路由协议

距离矢量路由协议(Distance-Vector Routing Protocol)

相关解释请参考维基百科百度百科
路由信息协议(Routing Information Protocol,简称RIP)是该协议的代表,是一种内部网关协议,属于应用层协议。
RIP有三个版本:

  • RIPv1:基于UDP 520接口的路由协议,使用分类路由器,不支持可变长度子网掩码,通过广播方式来传递消息。这个限制造成在RIPv1的网络中,在同级网络下无法使用不同的子网掩码。换句话说,在同一个网络下所有的子网数目都是相同的。另外,RIPv1的协议报文中没有验证字段,所以RIPv1不支持验证。
  • RIPv2: 支持路由聚合和无类别域间路由(Classless Inter-Domain Routing,CIDR);支持组播方式发送更新报文,只有运行了RIPv2的设备才能收到协议报文。支持对协议报文进行验证,增强安全性。
  • RIPng:RIPng(Routing Information Protocol next generation)在RFC 2080中被定义,主要是针对IPv6做一些延伸的规范。
    如下图所示,要求在路由器A和路由器B的所有接口上开启RIP功能,实现网络互连
    file

    1. 在路由器A上配置IP地址(略)
    2. 在路由器A上配置RIP。路由器B类型,不在赘述
      <R1>system-view
      [R1]rip // 进入RIP视图
      [R1-rip-1]version 2 // 配置RIP的版本为2,不写该语句则默认为版本1
      [R1-rip-1]undo summary // 取消路由聚合功能,不写该语句则默认聚合成标准的A、B、C类网络并告知邻居路由器
      [R1-rip-1]network 192.168.1.0 // 宣告直连网络192.168.1.0
      [R1-rip-1]network 192.168.4.0 // 宣告直连网络192.168.4.0
      [R1-rip-1]quit

链路状态路由协议

链路状态路由协议中的典型代表是OSPF(开放式最短路径优先)协议。RIP使用跳数作为度量值,而OSPF使用带宽作为度量值。OSPF使用SPF算法(Dijkstra算法)计算路由,从算法层面保证没有网络环路。
file
路由器分别在2个不同的区域内,现需实现各个路由器之间的路由互通。路由器A的配置如下

<R1>system-view  //进入系统视图
[R1]router-id 1.1.1.1 // 指定R1的Router ID为1.1.1.1
[R1]ospf  // 进入OSPF视图
[R1-ospf-1]area 0  // 进入区域0
[R1-ospf-1-area-0.0.0.0]network 172.16.10.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 172.16.11.0 0.0.0.255 // 宣告和自己相邻的网络,注意此处使用了反掩码
[R1-ospf-1-area-0.0.0.0]quit
[R1-ospf-1]area 1
[R1-ospf-area-0.0.0.1]nework 192.168.2.0 0.0.0.255

平衡混合路由协议

BGP(边界网关协议)是其中的典型代表。BGP在传输层使用TCP 179接口,提高了可靠性。BGP定义了几种消息类型,如Open、Update、Keepalive和Notification等

  • Open:TCP连接建立后发送的第一条消息,用于在BGP对等体之间建立会话
  • Update:用于在对等体之间交换路由信息
  • Keepalive:BGP周期性地向对等体发送Keepalive消息,以保持会话的有效性
  • Notification:用于处理BGP进程中的各种错误

Related Posts

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注